"Invalid referrer go back"

Can't find the answer to your question in the Knowledge Base? Post it here and we'll answer it as quickly as possible.

Moderator: Help Desk Team

Forum rules
About
This board is designated for Smack Jeeves related support. If you have a question about using the site or the forums, you've come to the right place.

Before Posting
Please browse/search the Knowledge Base & FAQs Forum for the answer to your problem before posting. It contains an extremely helpful, organized list of common help topics.

Got a Bug?
Post it in Bugs & Glitches, not here.

Rules

    1) Use descriptive titles for your threads. Example: "How do I upload comics?" Do not use vague titles like, "question," "HELP! ANYBODY??"

    2) Describe your problem in detail. Explain exactly what is wrong. Post images, screen shots, links, code snippets - whatever is relevant. The better the information you provide, the better the solution you will receive.

    3) One question per thread. Do not post multiple questions in one thread; that way, we can resolve questions individually. Make a new thread for each question you have, unless your questions are closely related.

    4) Be polite. The more polite you are, the more people will want to help you. Be patient, and we will help you find the solution to your problem.

If your question has been resolved, please say so. A thank you would also be nice. If your question has NOT been answered, say so in the original topic. If your topic has been moved to resolved, you may then AND ONLY THEN post a new topic regarding the same issue.

"Invalid referrer go back"

Postby Brother Parvus » October 8th, 2019, 1:03 pm

Something, either an upgrade of my browser or my OS[0], or something there at smackjeeves, has changed recently (last month or so). I can log in to my smackjeeves account and for some, but not all the comics I read on smackjeeves, I can comment successfuly but for others, like Unearth (Matt van Dinter should be a candidate for sainthood) I get not the expected comment pane with my username but one with spaces for topic and text, and when I submit the comment I receive the "Invalid Referrer" error message.

[0] Firefox 69.0.2, MacOS 10.13.6; I have yet to try Safari, if that'd make a difference
Code: Select all
^<@<.@*
}"_# |
-@$&/_%
!(ˆI@|=>
;`+$?^?
,#"~|)^G
User avatar
Brother Parvus
 
Posts: 5
Joined: June 12th, 2019, 6:49 pm
Location: The Uttermost West

Re: "Invalid referrer go back"

Postby eishiya » October 8th, 2019, 3:54 pm

Are you seeing the mobile reader for those comics, or their desktop/regular website? The "unexpected" page you're describing sounds like the normal desktop logged-in comment form. Does the mobile one usually show your username? Were you perhaps expecting the guest form?

Some comics on SJ have the mobile reader enabled and some don't, perhaps this problem is tied to that and that's why only some are broken. I tried to test this but for some reason I can't get the mobile reader to even show up on my phone, it keeps showing me the desktop site for every comic even when I request the mobile version, even my own comic where I know the mobile reader is enabled :|
Image
User avatar
eishiya
 
Posts: 9831
Joined: December 5th, 2009, 11:17 am

Re: "Invalid referrer go back"

Postby Brother Parvus » October 8th, 2019, 8:59 pm

I don't mobile, as I have no portaphone. Is there a way to coerce the site I'm viewing to present to me the other interface?
Code: Select all
^<@<.@*
}"_# |
-@$&/_%
!(ˆI@|=>
;`+$?^?
,#"~|)^G
User avatar
Brother Parvus
 
Posts: 5
Joined: June 12th, 2019, 6:49 pm
Location: The Uttermost West

Re: "Invalid referrer go back"

Postby Brother Parvus » October 8th, 2019, 9:04 pm

Corrigendum: I guess I've been seeing the mobile interface until recently, if that's the one which shows my username and avatar when I attempt to post a comment; only in the last several months have I ever seen the interface which does not show that information. Unearth and Ever Present and Scarred Eden are three which appeal greatly to me and which I'd love to appreciate again.
Code: Select all
^<@<.@*
}"_# |
-@$&/_%
!(ˆI@|=>
;`+$?^?
,#"~|)^G
User avatar
Brother Parvus
 
Posts: 5
Joined: June 12th, 2019, 6:49 pm
Location: The Uttermost West

Re: "Invalid referrer go back"

Postby eishiya » October 8th, 2019, 9:43 pm

To be honest, I have no idea what the mobile comment UI looks like, so I'm just guessing that it's the mobile one. Perhaps someone else can chime in.

The desktop one looks like this:
Image

Is this what you've started to see, or are you seeing something else?

Do you have a screenshot of the comment page you're used to seeing?
Image
User avatar
eishiya
 
Posts: 9831
Joined: December 5th, 2009, 11:17 am

Re: "Invalid referrer go back"

Postby Brother Parvus » October 9th, 2019, 11:03 am

Aha! What you're showing me is what I see. That's the one which yields the error message! It wasn't doing that earlier, but within a month or so it's been giving me the error message. Is it you or me wot broke?
Code: Select all
^<@<.@*
}"_# |
-@$&/_%
!(ˆI@|=>
;`+$?^?
,#"~|)^G
User avatar
Brother Parvus
 
Posts: 5
Joined: June 12th, 2019, 6:49 pm
Location: The Uttermost West

Re: "Invalid referrer go back"

Postby eishiya » October 9th, 2019, 12:37 pm

I have no idea, because that one works for me D: I still have no idea what other comment form there could be (aside from the mobile one) because the one I posted has been there for at least a decade and has always worked for me.

Have you tried another browser yet, to see if it also has the problem? I have the same browser (same version, even) as you but on Windows, and haven't experienced this problem, but it might be worth checking. It's possible that something (antivirus, browser security options or add-ons, or even your router) is scrubbing referrer info from the comment page, and SJ requires another SJ page to be a referrer to combat automated spam comments.
Image
User avatar
eishiya
 
Posts: 9831
Joined: December 5th, 2009, 11:17 am

Re: "Invalid referrer go back"

Postby Brother Parvus » October 9th, 2019, 10:13 pm

A) apologies; I'm old (born in '44) and I conflated the comicfury comment pane with the smackjeeves ditto.

2) I disabled the https everywhere add-on and now I can comment.

111) comicfury, wordpress, and discus do not misbehave like smackjeeves does in the presence of this add-on

IV) it isn't just the add-on; it's even with the add-on disabled when I explicitly include https in the URL that the problem exists. This is broken. Someone should fix it, STAT.
Code: Select all
^<@<.@*
}"_# |
-@$&/_%
!(ˆI@|=>
;`+$?^?
,#"~|)^G
User avatar
Brother Parvus
 
Posts: 5
Joined: June 12th, 2019, 6:49 pm
Location: The Uttermost West

Re: "Invalid referrer go back"

Postby eishiya » October 10th, 2019, 7:13 am

A. Well, that's that mystery solved :D

2-4: SJ was in the midst of transitioning to full HTTPS when it was bought by NHN and it looks like progress on that stalled, as there have been zero updates since that (except for a new TOS, naturally). Currently, only the main site works with HTTPS and on comic sites, HTTPS is not supported. It's definitely something to work on, but I have no idea what NHN are up to or how to contact them :/
Oddly, I also use HTTPS Everywhere but it does not force SJ comic sites to HTTPS, so I hadn't noticed the problem. When I manually go to https, I get the same referrer problem you do.
Image
User avatar
eishiya
 
Posts: 9831
Joined: December 5th, 2009, 11:17 am


Return to New Questions

Who is online

Users browsing this forum: No registered users and 6 guests